]> ruin.nu Git - germs.git/blobdiff - src/test/CMakeLists.txt
Make it possible to build statically against the included fann library.
[germs.git] / src / test / CMakeLists.txt
index c6f82f75e3518c057e139d4deeff017f60437b56..e5ef629d52027561e7bd4a976592448e2f0f4863 100644 (file)
@@ -1,14 +1,16 @@
-PROJECT(GeneSort)
-
 SET(CMAKE_VERBOSE_MAKEFILE OFF)
 
-ADD_DEFINITIONS(-Wall -O2)
+#ADD_DEFINITIONS(-Wall -O2)
+
+#ADD_DEFINITIONS(-Wall -pedantic -g -D_GLIBCXX_DEBUG)
+
 
 
-SET(TESTSRC geneordertest)
+SET(TESTSRC geneordertest genealgorithmstest modelidentifiertest
+       genesortertest componenttreetest)
 
 ADD_EXECUTABLE(tester main ${TESTSRC})
-TARGET_LINK_LIBRARIES(tester GeneSort cppunit)
+TARGET_LINK_LIBRARIES(tester ${GENELIBS} cppunit)
 
 #find_package(Qt3)